Search found 3 matches

by scruss
Fri 17 Aug 2018, 20:30
Forum: BBC BASIC language
Topic: BBC on linux
Replies: 10
Views: 4169

Re: BBC on linux

I would recommend that you try both BBCSDL and Brandy and see which you prefer. As BBCSDL is a lot more powerful and more polished, I think it would be the best choice. Note, though, that BBCSDL under x86 Linux is only 32-bit. It no longer runs on my x86_64 Ubuntu machine, even after installing all...
by scruss
Sun 13 May 2018, 13:24
Forum: Desktop platforms and IDEs
Topic: BBCSDL doesn't work in Ubuntu 18.04: "arguments to dbus_message_new_method_call() were incorrect"
Replies: 0
Views: 2936

BBCSDL doesn't work in Ubuntu 18.04: "arguments to dbus_message_new_method_call() were incorrect"

BBCSDL for Linux x86 (Feb 2 2018 build) isn't starting on my Ubuntu 18.04 x86_64 machine. The error message it gives is: dbus[3257]: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file ../../../dbus/dbus-message.c line 1362. This is normally a bug in s...
by scruss
Sat 12 May 2018, 02:01
Forum: Desktop platforms and IDEs
Topic: Failed installation of BBC Basic to Raspberry Pi
Replies: 2
Views: 1916

Re: Failed installation of BBC Basic to Raspberry Pi

If you do

Code: Select all

unzip bbc-rpi.zip -d ~/BBCBASIC
cd ~/BBCBASIC
you won't go far wrong.

Incidentally, BBC Basic won't run on a Raspberry Pi Zero. It fails with "Illegal Instruction". I guess it was built for the 2 and 3 only.