BBCSDL doesn't work in Ubuntu 18.04: "arguments to dbus_message_new_method_call() were incorrect"

Discussions related specifically to the Windows, Linux (86), Mac OS-X and Raspberry Pi editions of BB4W and BBCSDL
Post Reply
scruss
Posts: 2
Joined: Fri 11 May 2018, 21:17

BBCSDL doesn't work in Ubuntu 18.04: "arguments to dbus_message_new_method_call() were incorrect"

Post by scruss » Sun 13 May 2018, 13:24

BBCSDL for Linux x86 (Feb 2 2018 build) isn't starting on my Ubuntu 18.04 x86_64 machine. The error message it gives is:

Code: Select all

dbus[3257]: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file ../../../dbus/dbus-message.c line 1362.
This is normally a bug in some application using the D-Bus library.

  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted (core dumped)
The libegl1-mesa-drivers:i386 package is no longer available under Ubuntu, but running ldd ./bbcsdl doesn't show any missing libraries. The versions of the required libraries:

Code: Select all

libegl1-mesa:i386 	:  18.0.0~rc5-1ubuntu1
libgl1-mesa-glx:i386 	:  18.0.0~rc5-1ubuntu1
libglapi-mesa:i386 	:  18.0.0~rc5-1ubuntu1
libsdl2-2.0-0:i386 	:  2.0.8+dfsg1-1ubuntu1
libsdl2-net-2.0-0:i386 	:  2.0.1+dfsg1-3
libsdl2-ttf-2.0-0:i386 	:  2.0.14+dfsg1-2
Any help would be greatly appreciated.

Post Reply