User Tools

Site Tools


dlls_20compatible_20with_20lbb

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

dlls_20compatible_20with_20lbb [2018/03/31 13:19] (current)
Line 1: Line 1:
 +=====DLLs compatible with LBB=====
  
 + LB Booster should be fully compatible with the following standard Windows DLLs. They have pre-assigned handles so do not need to be explicitly opened or closed in your programs:\\ \\ 
 +
 +| **DLL**\\ | **handle**\\ |
 +| ADVAPI32.DLL\\ | #advapi32\\ |
 +| COMCTL32.DLL\\ | #comctl32\\ |
 +| COMDLG32.DLL \\ | #comdlg32 \\ |
 +| GDI32.DLL\\ | #gdi32\\ |
 +| KERNEL32.DLL\\ | #kernel32\\ |
 +| SHELL32.DLL\\ | #shell32\\ |
 +| USER32.DLL\\ | #user32\\ |
 +| WINMM.DLL\\ | #winmm\\ |
 +\\  Many other DLLs, both supplied with Windows and available from third parties, are also compatible with LBB, but not all (although in most cases it should be possible to achieve compatibility by modifying LBB). The table below lists those DLLs whose status is known; if you have additional information please add it to the table:\\ \\ 
 +
 +| **DLL**\\ | **Publisher**\\ | **Status**\\ | **Notes**\\ |
 +| ATL.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| AVICAP32.DLL\\ | Microsoft\\ | OK\\ | Requires LBB v2.62 or later\\ |
 +| BB4WMAPM.DLL\\ | PlanarSoft\\ | OK\\ | \\ |
 +| CARDS32.DLL\\ | Microsoft\\ | OK\\ | Not supplied with Windows 7/8\\ |
 +| CodeAChrome51.DLL \\ | Alyce Watson\\ | No\\ | Seems not to scroll properly\\ |
 +| D3D8.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| DWMAPI.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| FMOD.DLL\\ | Firelight Technologies\\ | OK\\ | \\ |
 +| FTD2XX.DLL\\ | Future Technology Devices \\ | OK\\ | \\ |
 +| FTP4W32.DLL\\ | ?\\ | OK\\ | \\ |
 +| GDIPLUS.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| HardwareIDExtractorC.dll \\ | Cubic Design\\ | OK\\ | \\ |
 +| HHCTRL.OCX\\ | Microsoft\\ | OK\\ | \\ |
 +| IMAGE323.DLL\\ | Alyce Watson\\ | OK\\ | GetLongPixelColor not reliable\\ |
 +| INPOUT32.DLL\\ | Hirez\\ | OK\\ | Not the Logix4U version\\ |
 +| JPEG.DLL\\ | ?\\ | OK\\ | \\ |
 +| K8055D.DLL\\ | Velleman\\ | OK\\ | \\ |
 +| LB3_toolbars.dll\\ | ?\\ | OK\\ | Requires LBB v2.60 or later\\ |
 +| LBBROWSE3.DLL\\ | Alyce Watson\\ | OK\\ | May be unreliable\\ |
 +| LBRTF2.DLL\\ | Alyce Watson\\ | OK\\ | Requires LBB v2.80 or later\\ |
 +| MSVFW32.DLL\\ | Microsoft\\ | OK\\ | Requires LBB v2.80 or later\\ |
 +| NTPORT.DLL\\ | ZealSoft Studio\\ | OK\\ | 32-bits only?\\ |
 +| OLE32.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| OLEAUT32.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| OPENGL32.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| POWRPROF.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| RICHED32.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| SHLWAPI.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| URLMON.DLL\\ | Micorsoft\\ | OK\\ | \\ |
 +| WININET.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| WINRING0.DLL\\ | OpenLibSys.org\\ | OK\\ | Obsolete\\ |
 +| WINSPOOL.DRV\\ | Microsoft\\ | OK\\ | \\ |
 +| WMLIBERTY.DLL\\ | Bay Six Software\\ | OK\\ | May not always work\\ |
 +| WS2_32.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +| WSOCK32.DLL\\ | Microsoft\\ | OK\\ | \\ |
 +\\  If you know of a DLL which is not compatible with LBB, but you would like it to be, please post a request at the [[http://​lbb.conforums.com|forum]].
dlls_20compatible_20with_20lbb.txt ยท Last modified: 2018/03/31 13:19 (external edit)